Mes objets sont noir

Voir le sujet précédent Voir le sujet suivant Aller en bas

Mes objets sont noir

Message par Thierry le Ven 22 Nov 2013 - 6:54

Bonjour

Je suis en train de créer un circuit pour Raceret mes objets sont noir.
Je pense que cela vient de l'éclairage de ma scène.
J'ai aucune valeurs concernant le gfx.sun dans tracked.ini.
Donc je suppose qu'il ne doit pas y avoir un éclairage par défaut.

Quelqu’un peut il me donner un exemple de tracked.ini avec un bon éclairage de scène ou me dire si mon problème peut venir d'un autre endroit.

Merci

Thierry

Thierry
Débutant

Nombre de messages : 25

Revenir en haut Aller en bas

Re: Mes objets sont noir

Message par SkYbH le Ven 22 Nov 2013 - 11:37

Salut,

Oui il y'a fort a parier que ça soit ça, je pourrais avoir une image in game? Et tu est sous quelle version de Racer?

_________________

http://skybh.jimdo.com
avatar
SkYbH
Admin

Nombre de messages : 1297

http://skybh.jimdo.com

Revenir en haut Aller en bas

Re: Mes objets sont noir

Message par Thierry le Sam 23 Nov 2013 - 0:48

Bonjour

Merci pour ton aide.
Je t'ai mis ci joint une image de mes objets tests sous tracked.
Sous racer j'ai un peu de mal à me positionner au départ. (Chaque chose en son temps)
Il faut te dire que je suis débutant sous Racer. Mon expérience est sur d'autres moteurs temps réel.
J'ai modélisé un circuit sous 3DSMax, je l'exporte en .3ds pour le lire sous Zmodeler1 et l'exporter en .dof.
Voilà ma chaîne de création, il est important que tu la connaisses.
J’espère que c'est la plus optimum en partant de Max.
J'utilise la version 8.35 de Racer.
Fichiers joints
pb_racer.jpg Vous n'avez pas la permission de télécharger les fichiers joints.(50 Ko) Téléchargé 1 fois

Thierry
Débutant

Nombre de messages : 25

Revenir en haut Aller en bas

Re: Mes objets sont noir

Message par SkYbH le Dim 24 Nov 2013 - 0:56

Bonjour,

Alors oui, faire un copier/coller du fichier special.ini et du dossier TOD carswood, petite question bete, tu a fais le shader?

Autre chose, n'exporte jamais en .3ds, parce que apres tu pers les "normales" , pour ma part j'exporte en .obj, j'importe l'obj sous zmod2 et j'exporte en fichier zm1 (bien cocher la case flip YX axis lors de l'export depuis 3ds)

_________________

http://skybh.jimdo.com
avatar
SkYbH
Admin

Nombre de messages : 1297

http://skybh.jimdo.com

Revenir en haut Aller en bas

Re: Mes objets sont noir

Message par Thierry le Dim 24 Nov 2013 - 23:16

Bonjour

Oui j'ai bien mis un shader.

Je n'ai pas Zmodeler2. Je suis prêt à l'acheter, mais justement, je voulais faire le test au complet pour être certain d'acheter les bons outils.
Zmodeler2 est il toujours en vente ?
Ne faut il pas acheter Zmodeler3 ?

Voilà, il y a t il un moyen de faire mes tests (licence durée limité) et ensuite d'acheter la licence qui me convienne?

Merci

Thierry
Débutant

Nombre de messages : 25

Revenir en haut Aller en bas

Re: Mes objets sont noir

Message par SkYbH le Mar 26 Nov 2013 - 4:17

Bonjour,

Alors pour zmodeler2, il est toujours en vente, mais pas possible de juste tester... Et c'est une même et unique licence je crois Sad

Par contre depuis 3dsmax, tu peut exporter en .ase?

_________________

http://skybh.jimdo.com
avatar
SkYbH
Admin

Nombre de messages : 1297

http://skybh.jimdo.com

Revenir en haut Aller en bas

Re: Mes objets sont noir

Message par Thierry le Jeu 28 Nov 2013 - 21:03

Bonjour.

Oui MAX=>ASE c'est la chaîne de prod que j'utilise, je voulais juste en essayer d'autres car j'ai un problème pour récupérer sous Racer mes matrices de plaquage textures faite sous Max.
Si tu as une idée ? Je fais simplement une projection plane en " UVW Map "

Pour mes objets noirs, j'ai trouvé le problème. J'avais simplement laissé trainer un } en trop dans mon fichier shader. Embarassed Faute de débutant.

Merci encore 

Thierry
Débutant

Nombre de messages : 25

Revenir en haut Aller en bas

Re: Mes objets sont noir

Message par Thierry le Ven 29 Nov 2013 - 7:34

Bonsoir.

C'est bon aussi pour mon problème de texturation.
Ma texture n'était pas au bon ratio. Classique ne pas oublier les bases 256; 512; 1024 ....

Thierry
Débutant

Nombre de messages : 25

Revenir en haut Aller en bas

Re: Mes objets sont noir

Message par SkYbH le Ven 29 Nov 2013 - 12:35

Donc si j'ai bien compris la majorité des problèmes sont résolus? Smile
Autre question, ça sera quel type de circuit?

_________________

http://skybh.jimdo.com
avatar
SkYbH
Admin

Nombre de messages : 1297

http://skybh.jimdo.com

Revenir en haut Aller en bas

Re: Mes objets sont noir

Message par Thierry le Mar 3 Déc 2013 - 4:40

Bonjour

Oui mes problèmes sont résolus, cela évolue bien.
Mais dans ce type de travaux, plus on avance et plus il y en a des nouveaux qui arrivent.
Mon problème actuel, c'est la transparence sur la végétation que je ne vois pas.
La texture est bonne, car quand je l'a plaque sur un objet issu de "carlswood_nt" il y a de la transparence.
Mais quand je met sur un de mes objets la texture trees01 de "carlswood_nt" elle n'est plus transparente.
Voilà il faut que je trouve la bonne case à cocher. Si tu as une idée ?

Je fais un petit circuit moto/karting 1,2 km.

Thierry
Débutant

Nombre de messages : 25

Revenir en haut Aller en bas

Re: Mes objets sont noir

Message par SkYbH le Sam 7 Déc 2013 - 0:08

Bonjour ,

Alors la comme j'ai plusieurs pistes, enfin en ayant relu, surtout une :
La solution la plus "bête" (enfin le shader le plus basique) serait de mettre :
Code:

blendfunc=blend
Sur le shader de la partie(layer de la texture, en general layer0) concernée et je pense que ça devrait être bon Smile

_________________

http://skybh.jimdo.com
avatar
SkYbH
Admin

Nombre de messages : 1297

http://skybh.jimdo.com

Revenir en haut Aller en bas

Re: Mes objets sont noir

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum